Welcome, Guest
Username: Password: Remember me

TOPIC: Incorrect voltages on op amp

Incorrect voltages on op amp 1 month 3 days ago #1886

  • LdCmd
  • LdCmd's Avatar
  • OFFLINE
  • New Member
  • Posts: 1
  • Karma: 0
So I have just finished building the pedal shield MEGA have only tested a few effects distortion, delay, tremolo but I don't think they are pronounced enough, and there is also some noise, so I started trouble shooting. The MEGA is an original Arduino board.

First check voltages :-)

The voltages were ok at the onboard measurements points, and at conn5 (~3.7V) and OLED screen voltages was ~5V, screen and buttons (checked with program) work ok. There is one place where the voltages are not the same as in the trouble shooting guide. On the op amp the voltage on pin 5,6,7 should be between 2.1 - 2.5 but in my case they are pin 5 = 1.42V, pin 6 = 2.92V, pin 6 = 2.87V I'm powering it of a 9V battery. I have looked at the resistors and they are placed correctly.

Also adjusting the RV1 doesn't seam to have any effect...

Anybody have a suggestion where I should look?
The administrator has disabled public write access.

Incorrect voltages on op amp 3 weeks 6 days ago #1890

  • Ray
  • Ray's Avatar
  • NOW ONLINE
  • Moderator
  • Posts: 664
  • Thank you received: 144
  • Karma: 40
The first things you should try is to retouch all the pins and pads with a soldering iron again.
It is easy to have a cold joint and debug one can take hours.

Don't worry about the oled pin voltages, some screens have slightly different voltages, so if it works let it be.

Your voltages are a bit out of the sweet spot but not too bad...
Have you tried the sine wave generator? are you able to generate a clean sinewave? (so the output stage is alright)

If you load a clean effect, you should feel that changing the RV1 resistor trimmer should change the level. It behaves in a logarithmic way, so you will see that most of the change happens in the Las 25% of the swipe.
The administrator has disabled public write access.
Time to create page: 0.085 seconds
Powered by Kunena Forum
Joomla SEF URLs by Artio